Wifi fungerar inte på bärbar dator [Löst]

Här diskuterar vi nätverksrelaterade problem eller projekt.

Wifi fungerar inte på bärbar dator [Löst]

Inläggav GHLJons » tis okt 06, 2020 9:20 pm

Hej

Jag har installerat Mint 20 Xfce på en gammal bärbar dator, en Fujitsu-Siemens AMILO-Li-2727.
Tyvärr lyckas jag inte få igång trådlöst nätverk. Nätverkskortet heter "Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 04)".

När jag klickar på nätverkssymbolen i panelen så rapporterar den "Trådlösa nätverk: frånkopplad".

Jag har sökt i olika fora på nätet under många timmar, men inte hittat någon lösning.
Tacksam för hjälp!
Senast redigerad av GHLJons tis okt 13, 2020 6:11 pm, redigerad totalt 1 gång.
GHLJons
Munk
 
Inlägg: 43
Blev medlem: sön apr 05, 2020 5:01 pm

Re: Wifi fungerar inte i på bärbar dator

Inläggav bosse » ons okt 07, 2020 6:44 am

Hej, vet inte om detta hjälper. Hittade drivrutiner ifall det saknas.
https://sciencespaces.com/notebooks/fuj ... 727/11782/

:?:
bosse
Finansiär och Beskyddare
 
Inlägg: 1043
Blev medlem: tis aug 12, 2014 7:25 am

Re: Wifi fungerar inte i på bärbar dator

Inläggav Mikael » ons okt 07, 2020 7:31 am

Lyser WiFi-lampan?
Verkar vara Fn+F1 för att "slå på" Wifi.
---
LMDE 6 Faye@Mintbox Mini 2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 2740
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Wifi fungerar inte i på bärbar dator

Inläggav GHLJons » ons okt 07, 2020 7:04 pm

Jag följde länken som Bosse skickade, men hittade bara drivrutiner för Windows. Jag antar att de inte fungerar i Windows, eller kan de göra det?

Wifi-lampan lyser inte. Det stämmer att Fn+F1 ska kunna slå på/av Wifi, enligt datorns bruksanvisning. Emellertid händer ingenting när man trycker den kombinationen. Det kanske bara fungerar i Windows, vilket var datorns ursprungliga operativsystem.

Jag kan tillägga att Wifi har fungerat tidigare på den här datorn med Ubuntu, men efter en uppdatering slutade det att fungera. Då borde ju drivrutinen finnas med i Ubuntu, och därmed även i Mint. Jag provade att installera senaste utgåvan av Xubuntu, men den ville inte heller kännas vid trådlöst nätverk, och nu samma sak med Mint.

Vad kan man göra?
GHLJons
Munk
 
Inlägg: 43
Blev medlem: sön apr 05, 2020 5:01 pm

Re: Wifi fungerar inte i på bärbar dator

Inläggav Mikael » ons okt 07, 2020 7:19 pm

Det finns några andra trådar här i denna avdelning som du skulle kunna kika i.
viewforum.php?f=31

Om du skriver lsmod i terminalen, får du då fram något med Qualcomm Atheros?
---
LMDE 6 Faye@Mintbox Mini 2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 2740
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Wifi fungerar inte i på bärbar dator

Inläggav bosse » ons okt 07, 2020 7:26 pm

Mitt första försök med LM med en gammal laptop fick jag att fungera genom tips här på forumet att backa till en äldre utgåva. Har du provat LM 18 alt 19. Kanske långsökt? :?
bosse
Finansiär och Beskyddare
 
Inlägg: 1043
Blev medlem: tis aug 12, 2014 7:25 am

Re: Wifi fungerar inte i på bärbar dator

Inläggav Mikael » ons okt 07, 2020 7:46 pm

Jag tror att drivers ska finnas redan för det kortet.
Bilagor
20201007204539.png
20201007204539.png (58.42 KiB) Visad 14589 gånger
20201007204556.png
20201007204556.png (18 KiB) Visad 14551 gånger
---
LMDE 6 Faye@Mintbox Mini 2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 2740
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Wifi fungerar inte i på bärbar dator

Inläggav GHLJons » ons okt 07, 2020 8:16 pm

Kommandot lsmod säger inget om Qualcomm Atheros, men ath5k förekommer i utskriften.
Här kommer ett litet utdrag:

anna@anna-AMILO-Li-2727:~$ lsmod
Module Size Used by
nls_iso8859_1 16384 1
snd_hda_codec_realtek 126976 1
snd_hda_codec_generic 81920 1 snd_hda_codec_realtek
ledtrig_audio 16384 2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_intel 53248 2
snd_intel_dspcfg 24576 1 snd_hda_intel
ath5k 151552 0
snd_hda_codec 135168 3 snd_hda_codec_generic,snd_hda_intel,snd_hda_codec_realtek
ath 36864 1 ath5k
snd_hda_core 90112 4 snd_hda_codec_generic,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep 20480 1 snd_hda_codec
mac80211 843776 1 ath5k
snd_pcm 106496 3 snd_hda_intel,snd_hda_codec,snd_hda_core
cfg80211 704512 3 ath,ath5k,mac80211

Rad 7 säger
Module ath5k, Size 151552, Used by 0

Det är ju lite anmärkningsvärt. Det verkar ju som om den inte används.

När jag tittar i filhanteraren så hittar jag ath5k.

Skärmbild_2020-10-07_21-08-05.png
Skärmbild_2020-10-07_21-08-05.png (36.21 KiB) Visad 14542 gånger



Jag har inte testat LM18 eller 19, men det kanske är värt ett försök om inget annat hjälper. Men först vill jag försöka med LM20.
GHLJons
Munk
 
Inlägg: 43
Blev medlem: sön apr 05, 2020 5:01 pm

Re: Wifi fungerar inte i på bärbar dator

Inläggav Mikael » ons okt 07, 2020 8:41 pm

GHLJons skrev:Det är ju lite anmärkningsvärt. Det verkar ju som om den inte används.

Nja, det stämmer väl egentligen, den fungerar inte för dig.

Kolla om det finns någon inställning i BIOS typ "wireless always on".
---
LMDE 6 Faye@Mintbox Mini 2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 2740
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Wifi fungerar inte i på bärbar dator

Inläggav Marie SWE » ons okt 07, 2020 8:52 pm

Som Mikael nämner, kolla så inte wifi't är inaktiverat i Bios.

Jag kör LMDE3 och jag har Qualcomm Atheros på två av mina bärbara och det fungerar felfritt.
Så en liten test du kan göra är att skapa en live-sticka med LMDE4 och se om wifi't fungerar där.

Bara för att utesluta hårdvaran... Jag antar att du hade windows i datorn innan du installerade Mint20. Hur länge sedan är det och fungerade nätverkskortet då?
Marie SWE
 

Re: Wifi fungerar inte i på bärbar dator

Inläggav GHLJons » ons okt 07, 2020 9:05 pm

I BIOS kan man ställa Wireless Device till Enabled eller Disabled.
Den står på Enabled.

Som jag skrev tidigare så fungerade det med Ubuntu, men försvann vid en uppdatering för två veckor sedan ungefär.
GHLJons
Munk
 
Inlägg: 43
Blev medlem: sön apr 05, 2020 5:01 pm

Re: Wifi fungerar inte i på bärbar dator

Inläggav Mikael » ons okt 07, 2020 9:07 pm

Minns du hur indikeringen för Wifi betedde sig då, med Ubuntu?
---
LMDE 6 Faye@Mintbox Mini 2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 2740
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Wifi fungerar inte i på bärbar dator

Inläggav Mikael » ons okt 07, 2020 9:11 pm

GHLJons skrev:När jag klickar på nätverkssymbolen i panelen så rapporterar den "Trådlösa nätverk: frånkopplad"

Om du där väljer Nätverksinställningar - hur ser det ut där?

Hos mig:
20201007220952.png
20201007220952.png (40.3 KiB) Visad 14468 gånger
---
LMDE 6 Faye@Mintbox Mini 2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 2740
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Wifi fungerar inte i på bärbar dator

Inläggav GHLJons » ons okt 07, 2020 9:23 pm

Det här är allt jag får fram.

Skärmbild_2020-10-07_22-20-36.png
Skärmbild_2020-10-07_22-20-36.png (11.79 KiB) Visad 14522 gånger
GHLJons
Munk
 
Inlägg: 43
Blev medlem: sön apr 05, 2020 5:01 pm

Re: Wifi fungerar inte i på bärbar dator

Inläggav GHLJons » ons okt 07, 2020 9:29 pm

Jag vet inte hur indikeringen för Wifi betedde sig tidigare. Det är min dotter som använder den här datorn normalt.
GHLJons
Munk
 
Inlägg: 43
Blev medlem: sön apr 05, 2020 5:01 pm

Nästa

Återgå till Nätverk

Vilka är online

Användare som besöker denna kategori: Google [Bot] och 6 gäster

cron